Well if you've been a programmer for any length of time, this better be something you're familiar with. If it's not... change and follow these rules for the sake of humanity.
I've had the joy over the past few months to work on two projects I inherited from others... the coding standards are killing me.
So lets work this out, lets say you have a text box for a name. The proper naming convention of that text box is NOT:
NameTxt.
The proper naming convention of this text box IS:
txtName
You see that.. the type of object goes in FRONT of the variable name.
There is this neat little trick we have available to us in modern IDE's. When I know I am looking to edit a Button I start by typing btn... and you know what happens? I get a pop up with all the buttons on my form.
I really thought this was programming 101... guess not.
So here are a few of my naming conventions, frankly I don't care if you follow this.. just be consistent so the person that follows you can figure it out!
Button: btn
Radio Button: rdo
Label: lbl
Text Box: txt
Drop Down List: ddl
Really is this that hard?